BLSA-2017:0043 – [紧急] nss/nss-util 安全警告及修复方法



  • BLSA-2017:0043 – [紧急] nss/nss-util 安全警告及修复方法

    问题描述

    NSS最近暴露一个越界写操作漏洞(CVE-2017-5461),恶意攻击者利用这个漏洞可导致使用NSS库的应用程序崩溃或者执行任意代码。建议所有使用受影响产品的用户都安装BCLinux提供的的更新补丁。

    nss简介
    网络安全服务(Network Security Services,简称NSS)是一组支持跨平台开发安全客户端与服务器应用程序的程序库,它提供服务器侧硬件TLS/SSL加速和客户端侧智能卡的可选支持。NSS提供了支持TLS/SSL及S/MIME的完全开源实现。
    nss-util简介
    nss-util包提供了用于网络安全服务(NSS)库的实用程序。

    影响版本

    • BigCloud Enterprise Linux 7
    • Red Hat Enterprise Linux 7
    • CentOS Linux 7

    详细介绍

    • CVE-2017-5461 [紧急]
      NSS在执行某些Base64解码操作时暴露出一个越界写操作漏洞,恶意攻击者可以利用这个漏洞,通过特制恶意证书,当NSS解析时,导致使用NSS库的应用程序崩溃,或者执行任意代码。

    解决方案

    目前,BCLinux的官方源已经提供 nssnss-util 更新软件包,受影响的 BCLinux 7 客户端用户需要升级到 3.28.4-1.0.el7_3 版本。

    1.检查YUM源设置,确保使用的是BCLinux官方YUM源

    [root@BCLinux ~]# ll /etc/yum.repos.d/
    total 16
    -rw-r--r--. 1 root root 1127 Jan  7  2016 BCLinux-Base.repo
    -rw-r--r--. 1 root root  794 Jan  7  2016 BCLinux-Kernel.repo
    -rw-r--r--. 1 root root 1153 Jan  7  2016 BCLinux-Source.repo
    -rw-r--r--. 1 root root  801 Jan  7  2016 BigCloud.repo
    

    2.安装更新

    [root@BCLinux ~]# yum update nss nss-util
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Resolving Dependencies
    --> Running transaction check
    ---> Package nss.x86_64 0:3.21.0-17.el7 will be updated
    --> Processing Dependency: nss = 3.21.0-17.el7 for package: nss-sysinit-3.21.0-17.el7.x86_64
    --> Processing Dependency: nss(x86-64) = 3.21.0-17.el7 for package: nss-tools-3.21.0-17.el7.x86_64
    ---> Package nss.x86_64 0:3.28.4-1.0.el7_3 will be an update
    --> Processing Dependency: nspr >= 4.13.1 for package: nss-3.28.4-1.0.el7_3.x86_64
    ---> Package nss-util.x86_64 0:3.21.0-2.2.el7_2 will be updated
    ---> Package nss-util.x86_64 0:3.28.4-1.0.el7_3 will be an update
    --> Running transaction check
    ---> Package nspr.x86_64 0:4.11.0-1.el7_2 will be updated
    ---> Package nspr.x86_64 0:4.13.1-1.0.el7_3 will be an update
    ---> Package nss-sysinit.x86_64 0:3.21.0-17.el7 will be updated
    ---> Package nss-sysinit.x86_64 0:3.28.4-1.0.el7_3 will be an update
    ---> Package nss-tools.x86_64 0:3.21.0-17.el7 will be updated
    ---> Package nss-tools.x86_64 0:3.28.4-1.0.el7_3 will be an update
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    =====================================================================================================================================================
     Package                                      Arch                                    Version                                           Repository   
    =====================================================================================================================================================
    Updating:
     nss                                          x86_64                                  3.28.4-1.0.el7_3                                  updates      
     nss-util                                     x86_64                                  3.28.4-1.0.el7_3                                  updates      
    Updating for dependencies:
     nspr                                         x86_64                                  4.13.1-1.0.el7_3                                  updates      
     nss-sysinit                                  x86_64                                  3.28.4-1.0.el7_3                                  updates      
     nss-tools                                    x86_64                                  3.28.4-1.0.el7_3                                  updates      
    
    Transaction Summary
    =====================================================================================================================================================
    Upgrade  2 Packages (+3 Dependent packages)
    
    Total download size: 1.6 M
    Is this ok [y/d/N]: y
    

    4.复查

    [root@BCLinux ~]# rpm -q nss nss-util
    nss-3.28.4-1.0.el7_3.x86_64
    nss-util-3.28.4-1.0.el7_3.x86_64
    

    5.重启应用

    安装升级包以后,重启应用,更新生效。

    外部链接

    1.BCLinux安全更新